aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2022-02-15 09:19:28 +0900
committerNIIBE Yutaka <[email protected]>2022-02-16 11:14:34 +0900
commitd98a78f0eb7711d32f473a04ea417e0f0bde6a00 (patch)
tree545d281b370c28c71603e7e1298fdc0947449e84
parent521500624b4b11538d206137205e2a511dad7072 (diff)
downloadlibgcrypt-d98a78f0eb7711d32f473a04ea417e0f0bde6a00.tar.gz
libgcrypt-d98a78f0eb7711d32f473a04ea417e0f0bde6a00.tar.bz2
libgcrypt-d98a78f0eb7711d32f473a04ea417e0f0bde6a00.zip
build: Remove checking Pth library.
* acinclude.m4 (GNUPG_PTH_VERSION_CHECK): Remove. * configure.ac (PTH_CFLAGS, PTH_LIBS): Remove. -- Fixes-commit: d918d8aee27987c3bb99f44a7ed3508d81009f51 Signed-off-by: NIIBE Yutaka <[email protected]>
-rw-r--r--acinclude.m463
-rw-r--r--configure.ac38
2 files changed, 0 insertions, 101 deletions
diff --git a/acinclude.m4 b/acinclude.m4
index 05bf88a7..306eb31d 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -327,66 +327,3 @@ int getpeername (int, $arg2 *, $t *);
[#include <sys/types.h>
#include <sys/socket.h>])
])
-
-
-# GNUPG_PTH_VERSION_CHECK(REQUIRED)
-#
-# If the version is sufficient, HAVE_PTH will be set to yes.
-#
-# Taken form the m4 macros which come with Pth
-AC_DEFUN([GNUPG_PTH_VERSION_CHECK],
- [
- _pth_version=`$PTH_CONFIG --version | awk 'NR==1 {print [$]3}'`
- _req_version="ifelse([$1],,1.2.0,$1)"
-
- AC_MSG_CHECKING(for PTH - version >= $_req_version)
- for _var in _pth_version _req_version; do
- eval "_val=\"\$${_var}\""
- _major=`echo $_val | sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\([[ab.]]\)\([[0-9]]*\)/\1/'`
- _minor=`echo $_val | sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\([[ab.]]\)\([[0-9]]*\)/\2/'`
- _rtype=`echo $_val | sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\([[ab.]]\)\([[0-9]]*\)/\3/'`
- _micro=`echo $_val | sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\([[ab.]]\)\([[0-9]]*\)/\4/'`
- case $_rtype in
- "a" ) _rtype=0 ;;
- "b" ) _rtype=1 ;;
- "." ) _rtype=2 ;;
- esac
- _hex=`echo dummy | awk '{ printf("%d%02d%1d%02d", major, minor, rtype, micro); }' \
- "major=$_major" "minor=$_minor" "rtype=$_rtype" "micro=$_micro"`
- eval "${_var}_hex=\"\$_hex\""
- done
- have_pth=no
- if test ".$_pth_version_hex" != .; then
- if test ".$_req_version_hex" != .; then
- if test $_pth_version_hex -ge $_req_version_hex; then
- have_pth=yes
- fi
- fi
- fi
- if test $have_pth = yes; then
- AC_MSG_RESULT(yes)
- AC_MSG_CHECKING([whether PTH installation is sane])
- AC_CACHE_VAL(gnupg_cv_pth_is_sane,[
- _gnupg_pth_save_cflags=$CFLAGS
- _gnupg_pth_save_ldflags=$LDFLAGS
- _gnupg_pth_save_libs=$LIBS
- CFLAGS="$CFLAGS `$PTH_CONFIG --cflags`"
- LDFLAGS="$LDFLAGS `$PTH_CONFIG --ldflags`"
- LIBS="$LIBS `$PTH_CONFIG --libs`"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <pth.h>
- ],
- [[ pth_init ();]])],
- gnupg_cv_pth_is_sane=yes,
- gnupg_cv_pth_is_sane=no)
- CFLAGS=$_gnupg_pth_save_cflags
- LDFLAGS=$_gnupg_pth_save_ldflags
- LIBS=$_gnupg_pth_save_libs
- ])
- if test $gnupg_cv_pth_is_sane != yes; then
- have_pth=no
- fi
- AC_MSG_RESULT($gnupg_cv_pth_is_sane)
- else
- AC_MSG_RESULT(no)
- fi
- ])
diff --git a/configure.ac b/configure.ac
index a9350c9c..f0f1637f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -766,44 +766,6 @@ AC_DEFINE(GPG_ERR_SOURCE_DEFAULT, GPG_ERR_SOURCE_GCRYPT,
[The default error source for libgcrypt.])
#
-# Check whether the GNU Pth library is available. We require this
-# to build the optional gcryptrnd program.
-#
-AC_ARG_WITH(pth-prefix,
- AS_HELP_STRING([--with-pth-prefix=PFX],
- [prefix where GNU Pth is installed (optional)]),
- pth_config_prefix="$withval", pth_config_prefix="")
-if test x$pth_config_prefix != x ; then
- PTH_CONFIG="$pth_config_prefix/bin/pth-config"
-fi
-if test "$enable_random_daemon" = "yes"; then
- AC_PATH_PROG(PTH_CONFIG, pth-config, no)
- if test "$PTH_CONFIG" = "no"; then
- AC_MSG_WARN([[
-***
-*** To build the Libgcrypt's random number daemon
-*** we need the support of the GNU Portable Threads Library.
-*** Download it from ftp://ftp.gnu.org/gnu/pth/
-*** On a Debian GNU/Linux system you might want to try
-*** apt-get install libpth-dev
-***]])
- else
- GNUPG_PTH_VERSION_CHECK([1.3.7])
- if test $have_pth = yes; then
- PTH_CFLAGS=`$PTH_CONFIG --cflags`
- PTH_LIBS=`$PTH_CONFIG --ldflags`
- PTH_LIBS="$PTH_LIBS `$PTH_CONFIG --libs --all`"
- AC_DEFINE(USE_GNU_PTH, 1,
- [Defined if the GNU Portable Thread Library should be used])
- AC_DEFINE(HAVE_PTH, 1,
- [Defined if the GNU Pth is available])
- fi
- fi
-fi
-AC_SUBST(PTH_CFLAGS)
-AC_SUBST(PTH_LIBS)
-
-#
# Check whether pthreads is available
#
if test "$have_w32_system" != yes; then